Go to Top

TELVES, v. 3.0.3.0

Upgrade software for midiELCOR, maxiElcor, miniElcor, nanoELCOR, picoELCOR, ELCOR-2, DATCOM-AMR2, DATCOM-AMR3, DATCOM-RTU.

– for devices with firmware version:

ELCOR-2, DATCOM-2 0.50 – 2.11
miniELCOR, maxiELCOR 0.00 – 4.03
nanoELCOR, picoELCOR 4.03 – 4.03
DATCOM-RTU 0.50 – 1.24
DATCOM-AMR-2, DATCOM-AMR3 1.00 – 4.03
DATCOM-K4 1.14 – 1.17
Share

Leave a Reply

Your email address will not be published. Required fields are marked *